What other bugs are there in VP ? | VP Bug Reporting | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
What other bugs are there in VP ?
March 20, 2011
10:03 pm
Avatar
David
Member
Members
Forum Posts: 646
Member Since:
March 20, 2010
sp_UserOfflineSmall Offline
1860sp_Permalink sp_Print

Thanks Phil, couldn't have said it better! I'm also giving them the benefit of the doubt because I know that they're listening to us and they're truly trying to give us the very best quality units and software they can. However, there will always be bugs in software. There is no such thing as perfect software....

David


 

 

 

March 20, 2011
1:20 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
1842sp_Permalink sp_Print

These are very minor bugs and they are in VP, not the X10 units.
You don't need VP to use the 710 and now that we know about the update problem we can check the web page for updates.

Personally I've been very happy with Maggie's responses to problems.
Magellan, as a brand, has been around for a long time but MiTac is new and their people have done an outstanding job from day one.

There have been so few real problems with the X10 units that we have a tendency to jump all over anything that does go wrong!

I have never liked Vantage Point anyway & I almost never use it.
If they eventually make VP more useful and user friendly that would be nice but the new units work fine without VP.
I would like to see them get the 710 driving maps available to the rest of the world and then worry about VP.

Meanwhile VP gives me something to b__ch & moan about, and "that's a good thing" to quote Martha Stewart. 😛

P.S. Yes they didn't make an announcement, but they didn't know about the problem.
Your post got the rest of us alerted to a problem and Maggie has been very quick to address issues that this forum has encountered.
I'm still more than willing to give them the benefit of the doubt.

When in trouble or in doubt, run in circles, scream and shout

March 20, 2011
8:17 am
Avatar
KI4HLW
Member
Members
Forum Posts: 64
Member Since:
January 11, 2011
sp_UserOfflineSmall Offline
1839sp_Permalink sp_Print

I would say they should send an Email to all the owners who registered their units on the Maggy site, that's why people register.... but those are the accounts they lost a bunch of last month if I recall.

I love my x710, best GPS I ever owned even with the few bugs that still need to best worked out, and hopefully the new software is a prelude to a new firmware. But it looks like Maggy as a company is still struggling to get it together. I really do hope they pull out of it.

P.S. It's not even fair to say they are telling us on this site, because no announcement was made till after I asked where 2.04 could be found because another poster made reference to it.

- iPhone Repair @ http://www.irepairvero.com

March 19, 2011
8:51 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
1828sp_Permalink sp_Print

Yeah, that's cool.
But not all the people that have and use Vantage Point are lucky enough to be members of this forum. 🙂

When in trouble or in doubt, run in circles, scream and shout

March 19, 2011
8:45 pm
Avatar
David
Member
Members
Forum Posts: 646
Member Since:
March 20, 2010
sp_UserOfflineSmall Offline
1826sp_Permalink sp_Print

I don't beleive they knew about it before they released 2.04 the other day, however, they learned about it very quickly once the update was released - so they have knewn for a few days. But to be honest, there really wan't a way to fix it! Think about it - if they had release a 2.0b to fix the issue you wouldn't have received an update telling you - would you!!! So, they're telling you here at the forum! 🙂


 

 

 

March 19, 2011
8:24 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline

So let me get this straight, Maggie new about the bug that version 2 won't work the auto update?
How, exactly, did they think we would know about an update?
The download page says it's version 2 , unless you download what you think is version 2 you have no way to know about a version 2.04!
Why would anybody download version 2 if you already have version 2?

Was Maggie even thinking about telling anyone about the upgrade?
Or have they lost their customer list again? :huh:

This is great! Something to complain about. :woohoo:

When in trouble or in doubt, run in circles, scream and shout

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 8
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 801
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 47
Topics: 940
Posts: 7401
Newest Members:
Eric White, OSS-SAS
Administrators: jg_the_Prophet: 25, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply