310 Units Failing to Start Up .. No Ability to Connect to PC | GC 110 310 Repair & Service Questions & Solutions | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
310 Units Failing to Start Up .. No Ability to Connect to PC
We are investigating the phenomena that 310 units are coming in for repair that refuse to start up .. here are our findings so far ..
February 4, 2014
4:18 pm
Avatar
OSS-SAS
Admin
Forum Posts: 1
Member Since:
March 11, 2021
sp_UserOfflineSmall Offline

We would like to update this topic. 

If a 310 has lost the ability to connect via USB to a PC and the unit does not get into the Service Mode we cannot repair it.

A 310 that does not start up and/or when connected to the PC still does not connect or start up is a "dead unit".

There are three reasons that we have found that can cause this:

1) Component failure due to a surge of electrical power to the unit.  For example; a bad DC adapter.

2) The Start Button is faulty.

3)  The Samsung XXC2443 ARM processors System Manager has been disrupted.

If your unit does start and goes to the Service Mode, in many cases we can repair this unit.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. For the record, JG received his moniker from the Kachins in Burma.  In Burmese he is "Dua Ma Rung".

September 17, 2013
10:23 am
Avatar
OSS-SAS
Admin
Forum Posts: 1
Member Since:
March 11, 2021
sp_UserOfflineSmall Offline

Further examination of this problem reveals that the Samsung XXC2443 ARM processors System Manager has been disrupted.

Internal Secure ROM data for booting cannot operate because any data in the SDRAM of the RISC chip has been disrupted by the effect of the loss of the Seiko 3.1VDC battery.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. For the record, JG received his moniker from the Kachins in Burma.  In Burmese he is "Dua Ma Rung".

September 16, 2013
11:57 am
Avatar
OSS-SAS
Admin
Forum Posts: 1
Member Since:
March 11, 2021
sp_UserOfflineSmall Offline

We are starting to encounter Explorist 310 units that cannot start up.

According to the customer they simple put the unit away for a year with batteries installed.

All ability for the unit to connect via USB cable to the PC has been terminated. Under these circumstances, there isn't any method to get into the service mode of the GPS to repair and reflash it.

Again, we find that this problem is related to units stored with batteries.

Our finds reveal that the depleted primary batteries are causing the 3.1 rechargeable battery in the unit to drop down to less than 0.1VDC and less than the 2.0 VDC necessary to maintain the SDRAM.

Unfortunately this battery does not have the ability to be recharged using either USB or battery power, so we replaced the rechargeable battery.  However; this step apparently does not work since the unit apparently may have critical data stored in Dynamic RAM lost.

Hence we are presently baffled as to the solution for the problem.

We are looking for member inputs on this situation.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. For the record, JG received his moniker from the Kachins in Burma.  In Burmese he is "Dua Ma Rung".

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 9
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply