Won't turn on | General GC | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Won't turn on
February 7, 2011
7:49 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
1388sp_Permalink sp_Print

Sarge104 wrote:

Same thing happens with my X710, going from lithium to rechargeables the unit thinks there is no battery power being supplied and the low battery alarm constantly goes off.

I also have the same thing happen if I don't change battery settings on both GC and 710.

Both units will not start up if the batteries are very low or it thinks they are low.

When in trouble or in doubt, run in circles, scream and shout

February 7, 2011
4:24 pm
Avatar
Sarge104
Member
Members
Forum Posts: 55
Member Since:
November 12, 2010
sp_UserOfflineSmall Offline
1385sp_Permalink sp_Print

Same thing happens with my X710, going from lithium to rechargeables the unit thinks there is no battery power being supplied and the low battery alarm constantly goes off.

February 7, 2011
1:31 am
Avatar
KI4HLW
Member
Members
Forum Posts: 64
Member Since:
January 11, 2011
sp_UserOfflineSmall Offline
1383sp_Permalink sp_Print

Also make sure you have the proper battery type set in the settings, I noticed weird things happen when the batteries get low and you have it set to the wrong type.

- iPhone Repair @ http://www.irepairvero.com

February 7, 2011
12:11 am
Avatar
Miniwhip
Guest
Guests
1381sp_Permalink sp_Print

It's your batteries. I've had it happen too, always was no juice left.

February 6, 2011
11:25 pm
Avatar
Noid647
Member
Members
Forum Posts: 6
Member Since:
January 29, 2011
sp_UserOfflineSmall Offline
1380sp_Permalink sp_Print

I turned it off for a while and now it seems to work, the batteries are a little low though, I think i will replace them anyway.

Thanks

February 6, 2011
8:30 pm
Avatar
S!G
Member
Members
Forum Posts: 251
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
1379sp_Permalink sp_Print

Sounds funny, but have you checked for empty batteries?

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ

February 6, 2011
7:37 pm
Avatar
Noid647
Member
Members
Forum Posts: 6
Member Since:
January 29, 2011
sp_UserOfflineSmall Offline

Had a great day yesterday hiking and finding caches. Today my GC will not turn on. It begins to start and I get the Magellan screen for a second and then it turns off. Any advice?

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 3
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply