Problems with GC compass | General GC | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Problems with GC compass
May 8, 2012
11:30 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
6031sp_Permalink sp_Print

There are no compass settings on the GC, it only works when it detects movement using gps to determine movement.

Make sure you are getting a satellite signal when it does point the wrong way.

And almost dead batteries may cause you to lose signal lock or stop the compass from working.

When in trouble or in doubt, run in circles, scream and shout

May 8, 2012
3:13 pm
Avatar
soleful2001
Member
Members
Forum Posts: 89
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
6030sp_Permalink sp_Print

Dont know if youhave tried this or not, but you can also check your compass settings.

You can set it to be triggered by how fast you are moving. not sure if this is available on the GC, but it has been on all the other units I have had both with an active compass and without.

May 5, 2012
12:09 pm
Avatar
Trail06
New Member
Members
Forum Posts: 2
Member Since:
October 17, 2011
sp_UserOfflineSmall Offline
5998sp_Permalink sp_Print

Thanks for the guidance. I have updated the firmware and am hoping this might fix the problem. I have had a few GPS and I am aware that the compass is triggered by movement but the problem is that when I walk the compass needle totally points in the wrong direction. I am wondering if it only occurs when I have flat batteries so I will try that as well.

April 29, 2012
6:11 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
5955sp_Permalink sp_Print

Again, the GC does not have a compass.

When in trouble or in doubt, run in circles, scream and shout

April 29, 2012
3:45 pm
Avatar
zpyder
Member
Members
Forum Posts: 24
Member Since:
April 6, 2012
sp_UserOfflineSmall Offline
5954sp_Permalink sp_Print

I had a similar issue but with a 710.

The batteries died in the unit, I took them out and put a new set in. Once the 710 had booted up, I noticed the compass/smart arrow was fixed in one direction, though the rest of the map updated whilst I walked.

I fixed the issue by going to settings and calibrating the compass. Very strange!

April 28, 2012
9:40 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
5948sp_Permalink sp_Print

In over two years with my GC I have never had the compass stop working if I was getting a good signal from the satellites and I was moving.

I would like to gently remind you that the GC does not have an electronic compass.
The compass gets it's data from the satellite signals, not from the magnetic field of the earth.
You have to be moving, with a satellite signal, for the compass to work.

When in trouble or in doubt, run in circles, scream and shout

April 28, 2012
5:17 pm
Avatar
wolf9545
Member
Members
Forum Posts: 37
Member Since:
October 22, 2010
sp_UserOfflineSmall Offline
5947sp_Permalink sp_Print

Do you know what version of firmware you have on your unit? You can check by going to:

[ul][li]tools[/li]
[li]settings[/li]
[li]all the way at the bottom is "product info" click on that[/li][/ul]
At the top it will state the software version, the current one is 1.7

If you don't have the current version you can go here, latest eXplorist GC firmware.

I am not too sure if any one of the updates in between the firmware you have and the current one might fix your problem.

April 28, 2012
1:44 pm
Avatar
Trail06
New Member
Members
Forum Posts: 2
Member Since:
October 17, 2011
sp_UserOfflineSmall Offline

This is mye first time on this forum and I am hoping somebody can be of assistance. The compass on my Explorist GC appears to be playing up if I leave it on for long periods of time.

I was caching today and after a few hours, the compass was pointing in the totally different direction to where I should have been heading. It has happened before but only after it had been switched on for a long period of time. Has anybody else had similar issues? Are there any fixes you recommend?

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 7
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 14
Forums: 41
Topics: 920
Posts: 7327
Newest Members:
bianca44d037, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 26, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply