New GC won't boot | General GC | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
New GC won't boot
June 16, 2011
3:10 pm
Avatar
dBMan
New Member
Members
Forum Posts: 2
Member Since:
June 15, 2011
sp_UserOfflineSmall Offline
3325sp_Permalink sp_Print

That's what I was afraid of... 🙁

June 16, 2011
7:26 am
Avatar
S!G
Member
Members
Forum Posts: 251
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
3324sp_Permalink sp_Print

I don't see anything, you could do, but returning the device. 🙁

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ

June 16, 2011
6:24 am
Avatar
dBMan
New Member
Members
Forum Posts: 2
Member Since:
June 15, 2011
sp_UserOfflineSmall Offline

Hello everyone. Sorry if this has been posted before. I just bought an eXplorist GC. Took it out of the box, put the batteries in and powered it on. The "Magellan" logo came on and it hung there. For hours. Overnight even. Never progressed past that. It was right next to a window so if it was looking for sats it should have not had a problem. I'm hoping to use the GPS this weekend on a family trip, but so far it's a brick. I tried connecting it to my PC to upgrade the firmware but the PC doesn't see the GPS (I installed the driver). I also tried to get in "developer mode" (Up+Menu+Power) and it didn't do anything (how long do you have to hold the three buttons?)

Any suggestions? Since I bought it from Amazon exchanging before the weekend is not an option. Any help would be appreciated.

Thanks.

Rich.

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 5
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply