eXplorist GC wont start | General GC | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
eXplorist GC wont start
unit will not turn on
January 2, 2014
9:57 pm
Avatar
OSS-SAS
Admin
Forum Posts: 1
Member Since:
March 11, 2021
sp_UserOfflineSmall Offline

Kristen, 

Since you are able to connect the USB cable between the PC and the GC then you will be able to go to a directory named /Geocaches.  You fill find this directory in the virtual drive named MAGELLAN .. something like F:/MAGELLAN/Geocaches.

Somehow one of your caches has poisoned the system.   Delete the contents of this directory but not the file "Top 999 in Worldwide.gpx".

After doing this, please make a backup copy of the COMPLETE GC to your PC for safety reasons.

Now restart the GC and if I am correct the unit will power up.

After it powers up go to TOOLS and settings and go to MEMORY and CLEAR THE MEMORY.  This will complete the repair sequence.

Let us know what happens.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. For the record, JG received his moniker from the Kachins in Burma.  In Burmese he is "Dua Ma Rung".

January 2, 2014
8:14 pm
Avatar
NurseKristen
New Member
Members
Forum Posts: 1
Member Since:
January 2, 2014
sp_UserOfflineSmall Offline

I've had my eXplorist GC for about 16 months and have never had a problem with it until the other day. I loaded up some caches as per usual and unplugged it from my computer and it would not turn on. I tried changing the batteries and it turned on for a couple of minutes and then died again. I have tried putting in new batteries a couple times now and it will only turn on while attached to the computer (with, oddly enough, my sister's garmin cord- it won't work with my magellan one). I tried updating it, but there has been no change. I unplug it from the computer and after holding the power button it will start to come on but when changing from the opening screen to the main menu it dies on me... What can I do? I really can't afford to buy a new one.

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 4
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 14
Forums: 41
Topics: 921
Posts: 7328
Newest Members:
KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 27, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply