Explorist GC Recognization | General GC | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Explorist GC Recognization
January 6, 2011
5:30 am
Avatar
cmoewes
Member
Members
Forum Posts: 60
Member Since:
April 28, 2010
sp_UserOfflineSmall Offline
1183sp_Permalink sp_Print

I mean, if the GC starts up and runs then there isn't anything wrong with the GPS. The issue is just with the PC setup.

You could also try disconnecting the GC. Then go into the device manager and look for that disbled usb device and then try deleting it. Then start up the GC (get to the main screen) and then plug it into the PC again. When the connect to pc/ power up screen comes on, select connect to pc. That should start the whole discovery process again.

Do you have access to another PC? Can you try it on another computer.

January 6, 2011
5:30 am
Avatar
cmoewes
Member
Members
Forum Posts: 60
Member Since:
April 28, 2010
sp_UserOfflineSmall Offline
1182sp_Permalink sp_Print

I mean, if the GC starts up and runs then there isn't anything wrong with the GPS. The issue is just with the PC setup.

You could also try disconnecting the GC. Then go into the device manager and look for that disbled usb device and then try deleting it. Then start up the GC (get to the main screen) and then plug it into the PC again. When the connect to pc/ power up screen comes on, select connect to pc. That should start the whole discovery process again.

Do you have access to another PC? Can you try it on another computer.

January 6, 2011
5:26 am
Avatar
cmoewes
Member
Members
Forum Posts: 60
Member Since:
April 28, 2010
sp_UserOfflineSmall Offline
1181sp_Permalink sp_Print

Have you tried starting it up in disk access mode?

Turn it off.

Connect the usb to the GC and the PC

Hold joystick up, menu and power to start in disk access mode.

See what happens there.

January 6, 2011
2:37 am
Avatar
Lakeport
Member
Members
Forum Posts: 5
Member Since:
January 2, 2011
sp_UserOfflineSmall Offline
1176sp_Permalink sp_Print

Well I've been on a couple of forums with this same problem and with all the bits of advice in addition to emailing Magellan directly, the same problem is there, consequently this brand new GPS will best be served as a paperweight, nothing more.

January 5, 2011
1:58 am
Avatar
Lakeport
Member
Members
Forum Posts: 5
Member Since:
January 2, 2011
sp_UserOfflineSmall Offline
1165sp_Permalink sp_Print

The GPS is still not being recognized after doing that exaxt process. When I got into the device manager screen, it shows as an unknown device, so I proceed with the driver update and it states that it could not find a better update and I get the computer to search in that Magellan Driver directory.

January 5, 2011
12:49 am
Avatar
David
Member
Members
Forum Posts: 646
Member Since:
March 20, 2010
sp_UserOfflineSmall Offline
1164sp_Permalink sp_Print

Go to the Control Panel > System > Device Manager > and open up the device and then update the driver pointing it to the driver files for the GPS...

David


 

 

 

January 5, 2011
12:34 am
Avatar
Lakeport
Member
Members
Forum Posts: 5
Member Since:
January 2, 2011
sp_UserOfflineSmall Offline
1163sp_Permalink sp_Print

Found that directory DavorF, do I have to move them anywhere or do anything with them? Even though the computer is saying that the GPS has no drivers.

January 4, 2011
10:21 pm
Avatar
DavorF
Member
Members
Forum Posts: 28
Member Since:
March 24, 2010
sp_UserOfflineSmall Offline
1162sp_Permalink sp_Print

After VP installation you should have folder "MagellanDrivers" on C: disk.
There are drivers for new explorists.

January 4, 2011
6:38 pm
Avatar
Lakeport
Member
Members
Forum Posts: 5
Member Since:
January 2, 2011
sp_UserOfflineSmall Offline
1160sp_Permalink sp_Print

I followed your instructions to the letter, yet the computer still says that the GC is not recognizable because the computer hasn't found any drivers for it.

January 4, 2011
5:07 pm
Avatar
cmoewes
Member
Members
Forum Posts: 60
Member Since:
April 28, 2010
sp_UserOfflineSmall Offline
1159sp_Permalink sp_Print

Does your GC start up ok?

Try this:

1. Disconnect the usb cable from the GC and the PC
2. Start up the GC (getting to the main menu)
3. Insert the usb cable into a different port on your PC(this should cause it to see the device as a new device)
4. Insert the usb cable into the GC.

Do you get the "Connect to PC" or "Power Only" screen? If so select Connect to PC

Also, on your GC, go into Tools->Settings->Connectivity and confirm you are in Connect to PC mode and not power only or NMEA.

January 4, 2011
2:13 pm
Avatar
Lakeport
Member
Members
Forum Posts: 5
Member Since:
January 2, 2011
sp_UserOfflineSmall Offline

For some reason, my computer doesn't want to recognize my GC, even after installing Vantage Point, Magellan Communicator & Firmware 1.6, any help on resolving the issue would be appreciated.

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 3
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply