Explorist GC doesn't powerup properly | General GC | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Explorist GC doesn't powerup properly
powers on but to fuzzy display
May 27, 2013
10:52 am
Avatar
bfordz
New Member
Members
Forum Posts: 1
Member Since:
May 27, 2013
sp_UserOfflineSmall Offline

I've used my GPS very little, as Rich969 stated, I purchased in the summer, used it once in the winter and now come spring I wanted to do some geocaching and it won't work.

The first time I powered it up it came on to a multi-colored fuzzy screen, I changed the batteries and it powered up fine. I uploaded approx 12 geocaches for the day and when I unplugged it from the usb cable it went back to the multi-colored fuzzy screen and now  that's all it will do.

I've tried several different batteries, even bought new ones. I did the reset button next to the usb connection but that hasn't done anythiing for it. I tried the multiple button pushes - Menu + joystick up + power button + reset. That did nothing also.

Any suggestions as to what happened to this gps? It's not even a year old yet.

 

TIA

brad

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 10
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply