USB Socket Loose – Electrical Circuit Broken | General 510 610 710 | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
USB Socket Loose – Electrical Circuit Broken
October 11, 2011
3:30 am
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline
4336sp_Permalink sp_Print

pprass wrote:

When I have the cable connected for uploading from the PC, it sometimes just falls out from the bottom of the GPS. I was wondering if I should expand the connector on the cable so that it forms a tighter fit?

This is a separate issue, the snugness of the fit of the USB socket and the USB plug (cord). With many connections/disconnections of the USB cord the snugness reduces and I have had the USB cord just dropout, I had wondered whether the angle of the socket was an attempt to prevent this from happening. But in doing so has caused the USD cord to exert too much force on the USB socket.

This thread is about the USB socket moving back and forth and interrupting the electrical connection.

Graham.

October 8, 2011
11:06 pm
Avatar
pprass
Member
Members
Forum Posts: 264
Member Since:
November 12, 2010
sp_UserOfflineSmall Offline
4329sp_Permalink sp_Print

I noticed that the socket was getting loose on my 610 ages ago. I just am now very careful whenever I put the cable in - ie I try not to wiggle it around to get it in.

When I have the cable connected for uploading from the PC, it sometimes just falls out from the bottom of the GPS. I was wondering if I should expand the connector on the cable so that it forms a tighter fit?

October 6, 2011
8:33 pm
Avatar
Lucky-Lizard
Member
Members
Forum Posts: 19
Member Since:
September 12, 2011
sp_UserOfflineSmall Offline
4318sp_Permalink sp_Print

Now that's amazing service right there! :cheer:

October 3, 2011
10:35 am
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline
4310sp_Permalink sp_Print

dwcarr1 wrote:

Graham,

I sent you a private message, but I never got a reply. However, Eric at Magellan wants to know if you would trade him your eX710 with the loose USB connector for a new unit. He would like to have the unit in order that they can see what is going on with the USB connector. If you're interested, please let me know. You can email me at [email protected].

Later,
David

David,

I have sent you a PM and email, happy to help in anyway.

Graham.

October 3, 2011
5:31 am
Avatar
David
Member
Members
Forum Posts: 646
Member Since:
March 20, 2010
sp_UserOfflineSmall Offline
4309sp_Permalink sp_Print

ShortcutHicksy wrote:

The USB socket on my 710 has become loose and this is causing the electrical connection to the printed circuit board to be intermittent. I have to move the USB cord around to locate a position where the electrical connection works. I will contact Magellan for repair. 🙁

Has anyone else experiencing this or noticed the USB socket is loose in their unit. It maybe worth check as my 710 is only 10 months old.

Graham.

Graham,

I sent you a private message, but I never got a reply. However, Eric at Magellan wants to know if you would trade him your eX710 with the loose USB connector for a new unit. He would like to have the unit in order that they can see what is going on with the USB connector. If you're interested, please let me know. You can email me at [email protected].

Later,
David


 

 

 

September 27, 2011
11:06 am
Avatar
S!G
Member
Members
Forum Posts: 251
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
4301sp_Permalink sp_Print

My socket is loose too. But has still full electrical cantact. I'm gonna try hotglue.

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ

September 27, 2011
9:57 am
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline
4300sp_Permalink sp_Print

Hi Phil,

It is definitely the socket; I have tried a number of different USB cords.

With the unit facing you, if you move the USB socket/cord towards the back, the electrical connection is broken. Move the USB socket/cord to the front of the unit and the electrical connection returns.

The USB socket moves in a vertical plane between the front and back of the unit (not in or out of the unit) and with my unit the electrical connect is now only there when the socket/cord is held towards the front of the unit.

Graham.

September 27, 2011
9:26 am
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
4299sp_Permalink sp_Print

My socket is still good but I broke a cable plug that I used with my 710.
I had to wiggle it to get a connection.
If you haven't yet, try another cable to make sure it's the socket and not your cable that's broken.

The first thing I noticed and complained about was the socket at an angle, it's a stupid design flaw that makes it very easy to damage the socket or cable plug.
Plus the cable has to be unplugged to mount or dismount the unit from a Magellan mount!

When I have it connected to the computer I have it on a mount attached to my desk to prevent the cable plug from resting on the desk and applying pressure to the socket.

When in trouble or in doubt, run in circles, scream and shout

September 27, 2011
8:14 am
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline

The USB socket on my 710 has become loose and this is causing the electrical connection to the printed circuit board to be intermittent. I have to move the USB cord around to locate a position where the electrical connection works. I will contact Magellan for repair. 🙁

Has anyone else experiencing this or noticed the USB socket is loose in their unit. It maybe worth check as my 710 is only 10 months old.

Graham.

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply