Latest FW verdict | Page 2 | General 510 610 710 | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Latest FW verdict
February 7, 2012
3:45 pm
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline
5247sp_Permalink sp_Print

I agree the compass is working and remains calibration like I have never seen it before. Find next nearest Geocache is also working at least 90% of the time.

Maybe try reloading the firmware upgrade again, you possible have a corrupt file as your 610 was previously working.

Graham.

February 7, 2012
2:30 pm
Avatar
denisetdoris
Member
Members
Forum Posts: 400
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
5246sp_Permalink sp_Print

Strange, I haven't recalibrated the compass since the upgrade. It stays calibrated no matter what battery type is selected, which profile I'm in, and whether on usb power or batteries.

Denis Gionet, OGA Executive Member - Northern Ontario.

February 7, 2012
12:10 pm
Avatar
pprass
Member
Members
Forum Posts: 264
Member Since:
November 12, 2010
sp_UserOfflineSmall Offline
5244sp_Permalink sp_Print

Now I am not so happy with the 6.32 upgrade. Compass no longer calibrates and "Next Nearest Geocache" still doesn't work.

I deleted all data - images, geocaches and the UGDS file and performed another defrag on the Magellan file and reloaded 6.32.

What else can I try?

February 5, 2012
12:39 am
Avatar
pprass
Member
Members
Forum Posts: 264
Member Since:
November 12, 2010
sp_UserOfflineSmall Offline
5236sp_Permalink sp_Print

Am happy with the upgrade. 41 seconds to boot up (although that was after I performed a defrag), screen seems to pan more easily, compass now calibrates (although again that worked after the defrag), but "Next Closest" function still doesn't work!

January 28, 2012
2:38 pm
Avatar
denisetdoris
Member
Members
Forum Posts: 400
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
5134sp_Permalink sp_Print

Has anyone else had an issue during startup with rechargeable batteries, and the unit set to Alkaline ? Mine won't start up correctly, gives me a Replace Battery warning twice, then goes to suspend mode. Press Power, and it loads up and finishes booting. Doesn't seem to do that with the unit set to Rechargeables. Maybe something had been changed in the Battery settings, David might know or be able to ask.

Compass is much more stable now though !

Denis Gionet, OGA Executive Member - Northern Ontario.

January 27, 2012
3:49 pm
Avatar
Morel
Guest
Guests
5116sp_Permalink sp_Print

No need to go into the track options menu every power up to "hide active track". The new FW retains this setting now through power on/off 🙂

January 26, 2012
3:40 pm
Avatar
Brent Owen
Member
Members
Forum Posts: 56
Member Since:
November 11, 2010
sp_UserOfflineSmall Offline
5105sp_Permalink sp_Print

My only issue with the firmware update is that they didn't proof read their updating instructions. :blink:

1. Turn on your eXplorist.
2. Allow the eXplorist to completed restart.
3. ....

They added a few more languages, but maybe they should perfect the English language first.

January 26, 2012
7:01 am
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline
5097sp_Permalink sp_Print

As one of the agitators on the compass problem from very early in 2011 (I think the issue was there from day one) I’m very pleased with the performance of the new firmware to date. This was a major performance hurdle for Magellan and if now fixed will allow them to concentrate on feature delivery.

I would like to extend a personal thank you to David, who answering my PM and worked tirelessly in the background pushing this issue with Magellan. Thanks David.

Graham.

January 26, 2012
2:23 am
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
5093sp_Permalink sp_Print

bkb wrote:

I only had two complaints about my 710, one was the spinning compass and it seems to be fixed. Works great so far. The other was the arrow size. I thought that there was a thread on here awhile back about the next firmware update having selectable arrow sizes but I don't see any option to change them with this update, am I missing something.

The thread about arrow size was more a wish list and a hope for selectable arrow size on the next FW.
There's no change on the arrow on this FW upgrade.

When in trouble or in doubt, run in circles, scream and shout

January 26, 2012
1:47 am
Avatar
denisetdoris
Member
Members
Forum Posts: 400
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
5091sp_Permalink sp_Print

I've had mine "shut down", or go into suspend mode after startup, this happened the 2 times I turned it on since the update. It functions perfectly once started, but it seems to pass out during startup. I'm not totally surprised though, it is a Windows-based OS after all ....

Denis Gionet, OGA Executive Member - Northern Ontario.

January 26, 2012
1:45 am
Avatar
Jaker
Member
Members
Forum Posts: 56
Member Since:
January 1, 2012
sp_UserOfflineSmall Offline
5090sp_Permalink sp_Print

bkb
Yep, everyone is reporting no problems, so far, with spinning or calibration of the compass
and that is great news indeed!
I don't think arrow size was addressed in this new FW release.

For the 710 -- (according to the release notes)
Added Brazilian-Portuguese language.
Added Turkish language.
Languages update.
Fix issue with device won’t start properly because of corrupted unit.xml file.
Fix issue with Compass Calibration function still active when sensor was turn OFF.
Fix issue with Position icon spinning.
Compass will now remain calibrated between power cycle or resume from suspend.
Fix issue with Geocache list not showing closest cache from Geocache hard button.

Jaker

January 26, 2012
1:13 am
Avatar
bkb
Member
Members
Forum Posts: 22
Member Since:
July 9, 2011
sp_UserOfflineSmall Offline
5088sp_Permalink sp_Print

I only had two complaints about my 710, one was the spinning compass and it seems to be fixed. Works great so far. The other was the arrow size. I thought that there was a thread on here awhile back about the next firmware update having selectable arrow sizes but I don't see any option to change them with this update, am I missing something.

January 25, 2012
2:40 am
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
5084sp_Permalink sp_Print

I've only done a few hours testing but it looks real good.
The compass works perfectly no matter what I do, the unit responds a bit better panning the map, with the same maps, tracks and GPX files as before the unit's speed is a little bit better changing pages and scrolling pages.

Time will tell if the compass remains stable but it looks good.

When in trouble or in doubt, run in circles, scream and shout

January 25, 2012
2:04 am
Avatar
soleful2001
Member
Members
Forum Posts: 89
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
5081sp_Permalink sp_Print

Mine is a little more responsive faster screen changes and panning. That could be because I deleted all the gpx files and have not added them back on. Compass is stable so far. after checking go to and cancelling the route compass stays calibrated and map is stable. This is great!

January 25, 2012
1:32 am
Avatar
Jaker
Member
Members
Forum Posts: 56
Member Since:
January 1, 2012
sp_UserOfflineSmall Offline

So --What is the general consensus or verdict for this latest FW update?

The compass calibration has certainly been fixed for me on my 610.
I only ever had one episode of the spinning compass, but before the update. I think that was addressed in #6 of the update (Fix issue with position icon spinning)- I haven't seen any feedback from anyone that may have had a serious problem with this issue before the update to determine if this has been resolved.
All and all, I believe, this update has vastly improved these units.

Jaker

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 6
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply