i need fimware v1.15 Explorist 310 | General 510 610 710 | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
i need fimware v1.15 Explorist 310
December 29, 2011
10:37 am
Avatar
Paganel
Member
Members
Forum Posts: 116
Member Since:
November 10, 2011
sp_UserOfflineSmall Offline
4782sp_Permalink sp_Print

Version 1.15 was only available to testers. The official version 1.12, 1.13, 1.17.
1.17 can be found here - http://support.magellangps.com.....,18,24,367

December 28, 2011
9:00 am
Avatar
bobxxlua1
New Member
Members
Forum Posts: 1
Member Since:
December 27, 2011
sp_UserOfflineSmall Offline

Hello, please send me the firmware version 1.15 explorist 310. on a support is 1.17. in the Internet and found none. Interested in this example can be 1.15 Put on depositfiles.com

thanks in advance

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 4
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply