Explorist 600 64Bit Win7 Driver | General 510 610 710 | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Explorist 600 64Bit Win7 Driver
September 1, 2011
2:44 am
Avatar
TozerBGood
New Member
Members
Forum Posts: 2
Member Since:
August 21, 2011
sp_UserOfflineSmall Offline
4149sp_Permalink sp_Print

OK after much tinkering and experimenting, I finally figured it out. It's embarrassing because it was actually kind of my fault.

I discovered my problem yesterday when I got out out my old...old...compaq presario (XP 32 Bit) laptop and tried to connect the Explorist 600 on it. As soon as I plugged in the
Explorist GPS, it gave me a message that the USB connection was bad. I had previously been able to connect it with this computer before, but it had been a while.

Just for grins, I unplugged the cable from the cable from the GPS and then put it back on upside down, and Lo & Behold it connected just fine on both the XP & WIN 7 64 bit computers.

There are 6 pin connections on the back of the Explorist, and it's not intuitive which way you turn the plug connector. There is an indentation on the bottom of the plug connection (on the GPS), which from appearance it looks like where the little extrusion on the cable plug should go.

Like I say, it is not intuitive, and it's not just me who thinks so. I showed the GPS and plug to a friend, and asked them what way it looks like it should be connected, and they did the same exact way I did, but that is obviously the wrong way.

Hmmm...just can't tell by appearance, and when in doubt, read the instructions I suppose.

Anyways, my problem is solved, and the GPS works fine with the 64 bIt Win 7 computer, and Topo 4.5.0.2 communicates just fine with it.

I also was able to get the Triton 500 to work with it as well, after much tinkering with it. The computer could see it just fine, but Topo couldn't download maps to it, but could transfer waypoints and such.

I finally emailed National Geographic Topo support, and they sent me a patch. Once I down loaded the patch, and DO NOT run the program in any special compatibility mode, but do run as administrator. That cured my problem with the Triton.

Hope that helps for anyone else having 64 Bit WIN 7 issues.

August 30, 2011
5:34 pm
Avatar
jmebd
Member
Members
Forum Posts: 184
Member Since:
March 26, 2011
sp_UserOfflineSmall Offline
4137sp_Permalink sp_Print

I am using Windows 7 64bit and do not have that file on my pc.... but I do have an x710 unit...shouldn't be that different tho

Here is a link to a file (can copy and paste it into wordpad or something and name it the mud.inf I guess if you're needing it).

http://www.tritonforum.com/Files/MUD.inf

Did you have a problem upon initial hookup of the unit? I did notice windows was "installing device driver" when I hooked mine up briefly (after a very recent full system wipe and OS reinstall but it was quite brief). Perhaps the above link will help. If not, you should be able to boot windows into safe mode and remove the device listed in device manager then reboot again and see if it installs again correctly.... you tried that?

Also, everything I'm reading regarding that file has to do with the Triton units???? I believe they also have the mud.sys file.... Can do a search on that site for locations and where to put the files but if I remember correctly, most of those types of files go in c:windowssystem32drivers folder..... but when installing I think they can be anywhere, just have to tell windows where to look.

August 30, 2011
3:34 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
4136sp_Permalink sp_Print

My pc is a Vista 32Bit laptop and I have never had an ex 600/500 etc unit so don't know about any issues with them.
I looked in my files but I have nothing for Windows 7 64Bit.

I'm sorry but I don't have anything to help you with.

When in trouble or in doubt, run in circles, scream and shout

August 30, 2011
1:59 pm
Avatar
TozerBGood
New Member
Members
Forum Posts: 2
Member Since:
August 21, 2011
sp_UserOfflineSmall Offline

Cant get a forum response to this question in the actual Explorist Section. Guess I'll post it here in the General section.

Can't get Explorist 600 to communicate with Windows 7 64 bit laptop. I tried the vista driver - doesn't work. Looking for a mud.inf file. Does anyone know about this?

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 6
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 42
Topics: 921
Posts: 7306
Newest Members:
savannahtindale, Wat, KHB3, ethanwetherspoon, EmilyAnges, cletachristie0, Robert Temple, OSS-SAS
Administrators: jg_the_Prophet: 29, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply