Magellan Website - HELP NEEDED!!! | Everything Else | Forums

Avatar
Please consider registering
guest
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Magellan Website - HELP NEEDED!!!
August 29, 2011
8:23 pm
Avatar
soleful2001
Member
Members
Forum Posts: 89
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
4124sp_Permalink sp_Print

I spoke with them on the phone. I did not get a clear answer as to why my order info was not on the website, however I did confirm that they are processing my order. They are also tracking my trade-in return for me so that shipment can go out faster.
All-in-All, I have not had a bad experience with Magellan except for the issues I had with VISTA and my Explorist 210. That made me run to Garmin for a while! no kidding

August 29, 2011
6:35 pm
Avatar
denisetdoris
Member
Members
Forum Posts: 400
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
4123sp_Permalink sp_Print

Odd, when I ordered my 610 (thru the Customer Loyalty program) I saw when they made the order, and saw the shipping process thru Canada Post's website, to track the order. Make the call, they'll send you the tracking info. Maybe they got your e-mail address wrong ? Something must be up.

Denis Gionet, OGA Executive Member - Northern Ontario.

August 29, 2011
6:06 pm
Avatar
soleful2001
Member
Members
Forum Posts: 89
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
4120sp_Permalink sp_Print

Is it normal business practice for someone to have 2 orders with MITaC and not see them on my account at the website?

MITaC charged me for my new unit, however I received no confirmation that the order shipped or anything. The only way I know this is that I saw the charge on my bank account.

I sent an email, but do not expect a response til tomorrow.

Probably should call. Not too worried at the moment, but...

August 17, 2011
3:49 am
Avatar
ShortcutHicksy
Member
Members
Forum Posts: 250
Member Since:
March 19, 2011
sp_UserOfflineSmall Offline
4032sp_Permalink sp_Print

David,

I have see it when using the menu system on the web site, and that would apply to us all. There have been examples in this forum, with links provided to presumably pages under development that you can not access via the site's normal menu system. That is pages that are not in the public domain section of the server.

Graham.

August 16, 2011
10:59 pm
Avatar
denisetdoris
Member
Members
Forum Posts: 400
Member Since:
March 17, 2010
sp_UserOfflineSmall Offline
4030sp_Permalink sp_Print

phild31 wrote:

Same with me, I don't rely on VP to notify me about updates so I check Magellan's site every few days for updates.

BTW, I just noticed that when I go to 'Support' I am logged out.
When I go to 'Software and Updates' it opens 'Support'.
So I logged back in, went to 'Support' and I was logged out again.
I cannot be logged in while on 'Support' on Magellan's web site.
It does it on FireFox and Internet Explorer.
Is that normal?

Same with me, the logging-out thing when you go to Support.

I also just go and check once in a while, for x10 and VP updates. Pretty lame site management, between the updates with passwords that disappear and reappear, and product you can't order for weeks on end until they fix a problem.......

Denis Gionet, OGA Executive Member - Northern Ontario.

August 16, 2011
10:00 pm
Avatar
phild31
Nashua, New Hampshire USA
Member
Members
Forum Posts: 1479
Member Since:
April 6, 2010
sp_UserOfflineSmall Offline
4029sp_Permalink sp_Print

Same with me, I don't rely on VP to notify me about updates so I check Magellan's site every few days for updates.

BTW, I just noticed that when I go to 'Support' I am logged out.
When I go to 'Software and Updates' it opens 'Support'.
So I logged back in, went to 'Support' and I was logged out again.
I cannot be logged in while on 'Support' on Magellan's web site.
It does it on FireFox and Internet Explorer.
Is that normal?

When in trouble or in doubt, run in circles, scream and shout

August 16, 2011
7:42 pm
Avatar
Morel
Guest
Guests
4023sp_Permalink sp_Print

Just went to the updates/downloads page of a specific device by following the normal page links. Not logged in to the site.

August 16, 2011
7:02 pm
Avatar
David
Member
Members
Forum Posts: 646
Member Since:
March 20, 2010
sp_UserOfflineSmall Offline

Ok guys, I need your help!

Over the past several months we've come across several pages that have required a password to download firmware updates - so, how did you find out about these links/pages?

Please let me know...
David


 

 

 

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 3
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 801
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 47
Topics: 940
Posts: 7401
Newest Members:
Eric White, OSS-SAS
Administrators: jg_the_Prophet: 25, mike_the_Enforcer: 0, OSS-SAS: 1

Leave a Reply