Firmware Update 510 | Software Issues | Forums

Avatar
Please consider registering
guest
sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_Feed Topic RSS sp_TopicIcon
Firmware Update 510
Problem with firmware update Explorist 510 from 7.13 to 7.24
July 11, 2014
11:22 am
Avatar
jg_the_Prophet
Admin
Forum Posts: 20
Member Since:
May 19, 2014
sp_UserOfflineSmall Offline

M,

In my professional opinion, the unit sent to you from Magellan as a replacement should have the latest firmware version and a set of the Australia/New Zealand Maps.

I would take the unit to the Dealer and have them update the firmware and see if it blows up.

My point is that the unit has to be tested with the new firmware and it should work.  Since the unit has a different serial number it should be loaded with the maps so that the you know that they are compatible.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go.

July 11, 2014
1:59 am
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

miaramra said

jgtechsupport said
M,

Thank you for the update.   We have worked so long on Magellan Explorists that my software team should be part of the MITAC.

We know exactly how the problem was created. They would have to Unbrand the unit and reinstall the BIOS.

Someone in production either used the wrong component or branded the unit with the wrong project software.

It is a shame that Dick Smith's group cannot arrange for you to receive from Magellan a "gratis" load of the complete Australia/New Zealand Summit and City Maps on a 8GB MicroSDHC card.

This would be a great gesture of support from Magellan and Dick Smith.

Again, thank you for your messages, I am sure that our members appreciate the wealth of information on these faulty units.

JG

Thanks once again for your reply and advice. I wish I knew more about where you fit in this support maze. I have talked extensively with the Australian Magellan support centre and the option of sending me Australia/New Zealand Summit and City Maps on a 8GB MicroSDHC card was never mentioned. You seem to know more about the device the local support group.Anyway, the unit is to picked up on Monday and returned to Magellan. An estimated 10 day turn around and I should have it back mid July. I hope this is not the norm for every firmware update from hereon.Confused

The saga continues. Below is my email to Magellan support. I returned my 4th faulty unit to them as requested and arranged. A week later a received a brand new unit.

"

Devy and Gilmoore,
 
I returned the fault unit for repairs as requested by your company. Today 11/07/2014 I received a new unit in a swap-out-arrangement.
The unit is loaded with SW Vers: 7.13
My original problem was caused by trying to update that version (7.13) to the next higher version. Why would you send me a brand new unit with the same old firmware? Now I'm  left with the same problem that I had a month ago? Do I update? Do I not? 
If I do, will it be work or will it not? The serial number of the device you sent me is very similar to the faulty units I returned to the retailers.
I requested and expected technical support from your company. I could have achieved the same outcome in a shorter period of time by swapping the faulty device at the retailer......for the 4th time.
So far, disappointed and disillusioned with Magellan.Yell
June 27, 2014
8:41 am
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

jgtechsupport said
M,

Thank you for the update.   We have worked so long on Magellan Explorists that my software team should be part of the MITAC.

We know exactly how the problem was created. They would have to Unbrand the unit and reinstall the BIOS.

Someone in production either used the wrong component or branded the unit with the wrong project software.

It is a shame that Dick Smith's group cannot arrange for you to receive from Magellan a "gratis" load of the complete Australia/New Zealand Summit and City Maps on a 8GB MicroSDHC card.

This would be a great gesture of support from Magellan and Dick Smith.

Again, thank you for your messages, I am sure that our members appreciate the wealth of information on these faulty units.

JG

Thanks once again for your reply and advice. I wish I knew more about where you fit in this support maze. I have talked extensively with the Australian Magellan support centre and the option of sending me Australia/New Zealand Summit and City Maps on a 8GB MicroSDHC card was never mentioned. You seem to know more about the device the local support group.Anyway, the unit is to picked up on Monday and returned to Magellan. An estimated 10 day turn around and I should have it back mid July. I hope this is not the norm for every firmware update from hereon.Confused

June 27, 2014
7:41 am
Avatar
jg_the_Prophet
Admin
Forum Posts: 20
Member Since:
May 19, 2014
sp_UserOfflineSmall Offline

M,

Thank you for the update.   We have worked so long on Magellan Explorists that my software team should be part of the MITAC.

We know exactly how the problem was created. They would have to Unbrand the unit and reinstall the BIOS.

Someone in production either used the wrong component or branded the unit with the wrong project software.

It is a shame that Dick Smith's group cannot arrange for you to receive from Magellan a "gratis" load of the complete Australia/New Zealand Summit and City Maps on a 8GB MicroSDHC card.

This would be a great gesture of support from Magellan and Dick Smith.

Again, thank you for your messages, I am sure that our members appreciate the wealth of information on these faulty units.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go.

June 27, 2014
3:02 am
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

I am now waiting for my third unit to be collected from me and returned to Magellan for repair.

As suggested, downloaded the tested patch from "website at http://www.jungleghost.com/Exp…..t_7_24.exe -" and once again all went well until the device rebooted. The message is slightly different " Update failed. Please Cold Start and try again". I hold down the power button the unit starts up again,  a progress bar at the bottom counts up to  100% and ends with "Update failed. Please Cold Start and try again". Around and around it goes.

Magellan support concedes that Dick Smith the reseller may have a faulty batch. I have replaced the previous faulty units with replacements from different outlets of the same store. So, now it's headed back for repairs and I haven't officially used it yet, two weeks of screwing around with a firmware update......disappointing introdution to the world og Magellan Explorists

June 21, 2014
8:48 am
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

Hi There,

jgtechsupport said

miaramra said

jgtechsupport said
M,

miaramra said

jgtechsupport said

miaramra said
Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport

M,

Yours is the second new 510 reported to us in one week that went into the iBoot mode when updated.

Please tell us the seller in Australia that you purchased the unit from.

JG

The seller is Dick Smith Electronics. I am about to return the unit to them and collect a replacement on advice from Magellan Support in Australia. I don't think I wil attempt the firmware upgrade this time.

M,

Please do not be afraid of the update.  You have to make sure that the GPS is working properly.  Just remember to always use FRESH AA batteries in the unit when you do the update.

Also NEVER USE VANTAGE POINT to do the updates.

Always use the FORCED UPDATE method .. meaning that you go to the http://www.magellangps.com website and DOWNLOAD the latest software update from their site directly.

If you are using VantagePoint to tell you when to do an update, please cancel this feature.  Just go to the bottom of your computer and right click on the VPLITE icon .. uncheck the start up command and then quit out.

This way VP will never lure you into using it as the update software.

JG

I picked up my replacement 510. I couldn't resist attempting the update again. I say it now, it was before reading the the reply above. My very first attempt was with Vantage Point. The update was downloaded using VP. So, on my second attempt I used that same file (no VP involved this time) and ALAS!! I now have the same problem---another paper weight. I am returning the device once more and seeking a refund.

If I knew for sure what the problem is and that it would not happen again I would consider a third attempt but this is getting embarrassing for all concerned. I am getting no feed back from Magellan.

M,

There are two possibilities. One, (the most likely) is that the dealer has inventory of bad units.  He can tell by the serial numbers as the sequence should be close to one another.  We know that a dealer in NYC (17th Street Photo) also had a bad batch of 510's that gave the same problem.

Second possibility is (the least likely) that the file you downloaded was corrupted with a bad internal file.  We have a tested Forced Update files on our website at http://www.jungleghost.com/Exp.....t_7_24.exe

In Conclusion, ask your dealer to do an update to prove that the batch of units he purchased were not a problem.   You are doing him a favor as if the batch is bad, he should be returning all the units to the distributor.

However; also warning him that if the batch is bad he will get the "iBoot" and if the update file was corrupt. The Magellan is at fault.

Let us know what happens.

JG

Hello again. I have the third GPS now and I have so far resisted the attempt to update the firmware. In agreement with the support rep here in Australia I will run the update when he gets back to me with an all clear. He is currently  researching the situation.

I will let you know how it pans out.

June 20, 2014
8:55 am
Avatar
jg_the_Prophet
Admin
Forum Posts: 20
Member Since:
May 19, 2014
sp_UserOfflineSmall Offline

miaramra said

jgtechsupport said
M,

miaramra said

jgtechsupport said

miaramra said
Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport

M,

Yours is the second new 510 reported to us in one week that went into the iBoot mode when updated.

Please tell us the seller in Australia that you purchased the unit from.

JG

The seller is Dick Smith Electronics. I am about to return the unit to them and collect a replacement on advice from Magellan Support in Australia. I don't think I wil attempt the firmware upgrade this time.

M,

Please do not be afraid of the update.  You have to make sure that the GPS is working properly.  Just remember to always use FRESH AA batteries in the unit when you do the update.

Also NEVER USE VANTAGE POINT to do the updates.

Always use the FORCED UPDATE method .. meaning that you go to the http://www.magellangps.com website and DOWNLOAD the latest software update from their site directly.

If you are using VantagePoint to tell you when to do an update, please cancel this feature.  Just go to the bottom of your computer and right click on the VPLITE icon .. uncheck the start up command and then quit out.

This way VP will never lure you into using it as the update software.

JG

I picked up my replacement 510. I couldn't resist attempting the update again. I say it now, it was before reading the the reply above. My very first attempt was with Vantage Point. The update was downloaded using VP. So, on my second attempt I used that same file (no VP involved this time) and ALAS!! I now have the same problem---another paper weight. I am returning the device once more and seeking a refund.

If I knew for sure what the problem is and that it would not happen again I would consider a third attempt but this is getting embarrassing for all concerned. I am getting no feed back from Magellan.

M,

There are two possibilities. One, (the most likely) is that the dealer has inventory of bad units.  He can tell by the serial numbers as the sequence should be close to one another.  We know that a dealer in NYC (17th Street Photo) also had a bad batch of 510's that gave the same problem.

Second possibility is (the least likely) that the file you downloaded was corrupted with a bad internal file.  We have a tested Forced Update files on our website at http://www.jungleghost.com/Exp.....t_7_24.exe

In Conclusion, ask your dealer to do an update to prove that the batch of units he purchased were not a problem.   You are doing him a favor as if the batch is bad, he should be returning all the units to the distributor.

However; also warning him that if the batch is bad he will get the "iBoot" and if the update file was corrupt. The Magellan is at fault.

Let us know what happens.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go.

June 19, 2014
8:37 pm
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

jgtechsupport said
M,

miaramra said

jgtechsupport said

miaramra said
Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport

M,

Yours is the second new 510 reported to us in one week that went into the iBoot mode when updated.

Please tell us the seller in Australia that you purchased the unit from.

JG

The seller is Dick Smith Electronics. I am about to return the unit to them and collect a replacement on advice from Magellan Support in Australia. I don't think I wil attempt the firmware upgrade this time.

M,

Please do not be afraid of the update.  You have to make sure that the GPS is working properly.  Just remember to always use FRESH AA batteries in the unit when you do the update.

Also NEVER USE VANTAGE POINT to do the updates.

Always use the FORCED UPDATE method .. meaning that you go to the http://www.magellangps.com website and DOWNLOAD the latest software update from their site directly.

If you are using VantagePoint to tell you when to do an update, please cancel this feature.  Just go to the bottom of your computer and right click on the VPLITE icon .. uncheck the start up command and then quit out.

This way VP will never lure you into using it as the update software.

JG

I picked up my replacement 510. I couldn't resist attempting the update again. I say it now, it was before reading the the reply above. My very first attempt was with Vantage Point. The update was downloaded using VP. So, on my second attempt I used that same file (no VP involved this time) and ALAS!! I now have the same problem---another paper weight. I am returning the device once more and seeking a refund.

If I knew for sure what the problem is and that it would not happen again I would consider a third attempt but this is getting embarrassing for all concerned. I am getting no feed back from Magellan.

June 19, 2014
11:29 am
Avatar
jg_the_Prophet
Admin
Forum Posts: 20
Member Since:
May 19, 2014
sp_UserOfflineSmall Offline

M,

miaramra said

jgtechsupport said

miaramra said
Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport

M,

Yours is the second new 510 reported to us in one week that went into the iBoot mode when updated.

Please tell us the seller in Australia that you purchased the unit from.

JG

The seller is Dick Smith Electronics. I am about to return the unit to them and collect a replacement on advice from Magellan Support in Australia. I don't think I wil attempt the firmware upgrade this time.

M,

Please do not be afraid of the update.  You have to make sure that the GPS is working properly.  Just remember to always use FRESH AA batteries in the unit when you do the update.

Also NEVER USE VANTAGE POINT to do the updates.

Always use the FORCED UPDATE method .. meaning that you go to the http://www.magellangps.com website and DOWNLOAD the latest software update from their site directly.

If you are using VantagePoint to tell you when to do an update, please cancel this feature.  Just go to the bottom of your computer and right click on the VPLITE icon .. uncheck the start up command and then quit out.

This way VP will never lure you into using it as the update software.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go.

June 18, 2014
11:32 pm
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

jgtechsupport said

miaramra said
Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport

M,

Yours is the second new 510 reported to us in one week that went into the iBoot mode when updated.

Please tell us the seller in Australia that you purchased the unit from.

JG

The seller is Dick Smith Electronics. I am about to return the unit to them and collect a replacement on advice from Magellan Support in Australia. I don't think I wil attempt the firmware upgrade this time.

June 18, 2014
9:48 pm
Avatar
jg_the_Prophet
Admin
Forum Posts: 20
Member Since:
May 19, 2014
sp_UserOfflineSmall Offline

miaramra said
Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport

M,

Yours is the second new 510 reported to us in one week that went into the iBoot mode when updated.

Please tell us the seller in Australia that you purchased the unit from.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go.

June 18, 2014
2:41 pm
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

Thanks for your advice. I will contact Magellan in Australia for further info.

 

jgtechsupport
June 18, 2014
9:53 am
Avatar
jg_the_Prophet
Admin
Forum Posts: 20
Member Since:
May 19, 2014
sp_UserOfflineSmall Offline

M,

Please return to whomever you purchased this unit from.  You can also call Magellan for a replacement.

You have an "iBoot" error.  It is not reparable.

JG

JG Technical Support is part of Jungle Ghost Enterprises (JGE) in Wayne, NJ. JG created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go.

June 18, 2014
8:43 am
Avatar
miaramra
Member
Members
Forum Posts: 8
Member Since:
June 18, 2014
sp_UserOfflineSmall Offline

I'm brand new at this with a brand new GPS explorist 510. I've been following the advice on updating the firmware to the letter. All went well until the unit restarted and now I have a blue screen with

Updating Image......

NOTE: this is Iboot fail

Please wait for the proced (that's all I can read on screen)

The display has been stuck this way about 30mins.

Is this normal? Do I have a serious problem?

A message at the beginning said not to disturb the unit during update process. Do I just leave it? Will the battery run flat before something happens?

HELP!

Forum Timezone: America/New_York
Most Users Ever Online: 99
Currently Online:
Guest(s) 6
Currently Browsing this Page:
1 Guest(s)
Top Posters:
phild31: 1479
David: 646
denisetdoris: 400
pprass: 264
S!G: 251
ShortcutHicksy: 250
jmebd: 184
Sockeye: 170
Caotix: 143
Paganel: 116
Member Stats:
Guest Posters: 5
Members: 805
Moderators: 0
Admins: 3
Forum Stats:
Groups: 15
Forums: 47
Topics: 935
Posts: 7396
Newest Members:
wendiaf2, Jackdsy, mistypn2, bonniegb16
Administrators: JG_Wiz_83: 178, jg_the_Prophet: 20, mike_the_Enforcer: 0

Leave a Reply