GC Won't get past the first screen | GC 110 310 Repair & Service Questions & Solutions | Forums

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
GC Won't get past the first screen
A current issue
April 17, 2014
10:52 am
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 289
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

BB, Somehow the update procedure corrupted some files.  If the unit is under warranty, call Magellan and return it.

If out of Warranty, install new batteries, attach GPS to PC and then simultaneously HOLD DOWN === UP ARROW, MENU and POWER ON.

This sequence should get the GPS to attach and create a virtual drive F:\Magellan.

Do not give up as sometimes this takes two or three attempts.

At this stage you have to replace all the files EXCEPT FOR THE MAP FILE.

Is this does not work then try the 310 Service Sequence BACK MENU BUTTONS AND POWER ON simultaneously.  I forget but you should see a master item to connect to the GPS.

Good Luck,

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

April 16, 2014
10:44 pm
Avatar
BigBanana
New Member
Members
Forum Posts: 1
Member Since:
April 16, 2014
sp_UserOfflineSmall Offline

Hi

So recently I updated my software to 2.15 and everything was running smoothly until I did that. Now on the first loading screen, the dial appears and makes a full revolution before stopping. Nothing else happens or appears except the magellan logo. Tried connecting to PC while device is off and holding Up, Menu and Power, but the same thing happens. Resetting the device also doesn't work. Batteries are good and working. Any help?

Forum Timezone: America/New_York

Most Users Ever Online: 451

Currently Online:
14 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

phild31: 1564

David: 677

denisetdoris: 422

S!G: 284

pprass: 280

ShortcutHicksy: 258

jmebd: 193

Sockeye: 173

Caotix: 142

Paganel: 120

Member Stats:

Guest Posters: 5

Members: 1625

Moderators: 0

Admins: 2

Forum Stats:

Groups: 15

Forums: 45

Topics: 1003

Posts: 7606

Newest Members:

Charlesnuh, Richardket, MelvinSkese, Mhasepet, Charleswaymn, Josepherm, GTA5ManTam, GennadiySar, TersulamD, Thomaspar

Administrators: JungleGhost: 289, Mike: 25


Comments

GC Won't get past the first screen | GC 110 310 Repair & Service Questions & Solutions | Forums — 1 Comment

    • PLEASE FORGIVE OUR AUTOMATED RESPONSE

    Concerning your inquiry on this website. Unfortunately, we do not respond to service questions posted in the comment section of this website. If you wish to have a member of our forum assist you with a solution then post a MESSAGE on this website. May we suggest, that you JOIN the Forum. MEMBERSHIP is FREE. Do a search for your problem. If you do not find the answer then please post your question under the appropriate section. Do not use the comments section or your inquiry will not be answered. Joining is free and in this manner, both we and our membership can provide solutions. This method will also help other members. Regards, JG

Add Comment Register



Leave a Reply