310 Units Failing to Start Up .. No Ability to Connect to PC | GC 110 310 Repair & Service Questions & Solutions | Forums

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
310 Units Failing to Start Up .. No Ability to Connect to PC
We are investigating the phenomena that 310 units are coming in for repair that refuse to start up .. here are our findings so far ..
February 4, 2014
4:18 pm
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 289
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

We would like to update this topic. 

If a 310 has lost the ability to connect via USB to a PC and the unit does not get into the Service Mode we cannot repair it.

A 310 that does not start up and/or when connected to the PC still does not connect or start up is a "dead unit".

There are three reasons that we have found that can cause this:

1) Component failure due to a surge of electrical power to the unit.  For example; a bad DC adapter.

2) The Start Button is faulty.

3)  The Samsung XXC2443 ARM processors System Manager has been disrupted.

If your unit does start and goes to the Service Mode, in many cases we can repair this unit.

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

September 17, 2013
10:23 am
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 289
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

Further examination of this problem reveals that the Samsung XXC2443 ARM processors System Manager has been disrupted.

Internal Secure ROM data for booting cannot operate because any data in the SDRAM of the RISC chip has been disrupted by the effect of the loss of the Seiko 3.1VDC battery.

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

September 16, 2013
11:57 am
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 289
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

We are starting to encounter Explorist 310 units that cannot start up.

According to the customer they simple put the unit away for a year with batteries installed.

All ability for the unit to connect via USB cable to the PC has been terminated. Under these circumstances, there isn't any method to get into the service mode of the GPS to repair and reflash it.

Again, we find that this problem is related to units stored with batteries.

Our finds reveal that the depleted primary batteries are causing the 3.1 rechargeable battery in the unit to drop down to less than 0.1VDC and less than the 2.0 VDC necessary to maintain the SDRAM.

Unfortunately this battery does not have the ability to be recharged using either USB or battery power, so we replaced the rechargeable battery.  However; this step apparently does not work since the unit apparently may have critical data stored in Dynamic RAM lost.

Hence we are presently baffled as to the solution for the problem.

We are looking for member inputs on this situation.

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

Forum Timezone: America/New_York

Most Users Ever Online: 451

Currently Online:
14 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

phild31: 1564

David: 677

denisetdoris: 422

S!G: 284

pprass: 280

ShortcutHicksy: 258

jmebd: 193

Sockeye: 173

Caotix: 142

Paganel: 120

Member Stats:

Guest Posters: 5

Members: 1625

Moderators: 0

Admins: 2

Forum Stats:

Groups: 15

Forums: 45

Topics: 1003

Posts: 7606

Newest Members:

Charlesnuh, Richardket, MelvinSkese, Mhasepet, Charleswaymn, Josepherm, GTA5ManTam, GennadiySar, TersulamD, Thomaspar

Administrators: JungleGhost: 289, Mike: 25


Comments

310 Units Failing to Start Up .. No Ability to Connect to PC | GC 110 310 Repair & Service Questions & Solutions | Forums — 1 Comment

    • PLEASE FORGIVE OUR AUTOMATED RESPONSE

    Concerning your inquiry on this website. Unfortunately, we do not respond to service questions posted in the comment section of this website. If you wish to have a member of our forum assist you with a solution then post a MESSAGE on this website. May we suggest, that you JOIN the Forum. MEMBERSHIP is FREE. Do a search for your problem. If you do not find the answer then please post your question under the appropriate section. Do not use the comments section or your inquiry will not be answered. Joining is free and in this manner, both we and our membership can provide solutions. This method will also help other members. Regards, JG

Add Comment Register



Leave a Reply