510 Upgrade Fails .. Error Message Product Identified Wrong | 510 610 710 Repair & Service Questions & Solutions | Forums

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
510 Upgrade Fails .. Error Message Product Identified Wrong
Some users have encountered some Magellan Explorist 510 units that were sold in Europe. When trying to upgrade them they get a Product Identified Error Message. Here is the solution.
January 7, 2020
4:16 pm
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 289
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

In case, you have run across this error when trying to upgrade your Magellan Explorist 510.  (See image blow) it is because your unit was programmed for the Europen market.

The upgrade for this is the firmware 7_30

Regards,

JG

http://www.jungleghost.com/Exp.....ailure.jpg

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

Forum Timezone: America/New_York

Most Users Ever Online: 451

Currently Online:
28 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

phild31: 1564

David: 677

denisetdoris: 422

S!G: 284

pprass: 280

ShortcutHicksy: 258

jmebd: 193

Sockeye: 173

Caotix: 142

Paganel: 120

Member Stats:

Guest Posters: 5

Members: 1596

Moderators: 0

Admins: 2

Forum Stats:

Groups: 15

Forums: 45

Topics: 1003

Posts: 7606

Newest Members:

Cyrillic, moveon, vanyuraJeri, nfyif, petraniaJeri, ArmeniaJeri, venus, vbnekzJeri, jackBoip, Darnellsainy

Administrators: JungleGhost: 289, Mike: 25


Comments

510 Upgrade Fails .. Error Message Product Identified Wrong | 510 610 710 Repair & Service Questions & Solutions | Forums — 1 Comment

    • PLEASE FORGIVE OUR AUTOMATED RESPONSE

    Concerning your inquiry on this website. Unfortunately, we do not respond to service questions posted in the comment section of this website. If you wish to have a member of our forum assist you with a solution then post a MESSAGE on this website. May we suggest, that you JOIN the Forum. MEMBERSHIP is FREE. Do a search for your problem. If you do not find the answer then please post your question under the appropriate section. Do not use the comments section or your inquiry will not be answered. Joining is free and in this manner, both we and our membership can provide solutions. This method will also help other members. Regards, JG

Add Comment Register



Leave a Reply