The Infamous iBOOT error .. final solution | Hardware Issues | Forums

Please consider registering
guest

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

   

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
The Infamous iBOOT error .. final solution
September 25, 2012
1:06 pm
alois
Member
Forum Posts: 19
Member Since:
March 17, 2010
Offline
12

My defective one is a normal eX610 manufactured around 2010 and by the way in a few days back from Czech Republik were the european repair center is located.
The "Touch" was a prototype unit i bought on ebay as a "eX610 without basemap". It seemed this one was stolen by one of the former holders at a convention.
Magellan replaced the unit for me and send me a new regular one. S1G got the prototype for collecting and played with it "to death". Wink

Since then he is interested to learn how to do a complete software refresh including the operating system part.

I have a second eXplorist 610, the newer one wich Magellan seems to build and ship since this year. That model doesn't record any track information within suspend mode wich the former models did.

The third unit i showed in a picture contains the same electronics as Magellan sells, but it's not from Magellan itself but from the same OEM that builds the eXplorist Touchscreen units for Magellan. That thing without a camera and other parts in it is a "Falk Lux 30".

http://goo.gl/bnszO

September 25, 2012
12:03 pm
S!G
Member
Forum Posts: 270
Member Since:
March 17, 2010
Offline
11

I know. But this unit has the "normal" old PCB, with the same ASSY as alois' new device has.

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ
September 24, 2012
2:39 pm
Mike
Guest
10

S!G said

For all of you, who don't know, what device we're talking about, this is the beauty:

http://up.picr.de/11943203lo.jpg

S1G,

I believe Alois and I were discussing different units. One was your Prototype Touch 610 .. one was his standard 610 and the new motherboards in Germany with the camera, etc. removed… aka PRO and the old PCB board.

Mike

September 24, 2012
1:39 pm
S!G
Member
Forum Posts: 270
Member Since:
March 17, 2010
Offline

For all of you, who don't know, what device we're talking about, this is the beauty:

http://up.picr.de/11943203lo.jpg

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ
September 20, 2012
2:12 pm
S!G
Member
Forum Posts: 270
Member Since:
March 17, 2010
Offline

Mike said

S!G said

Mike,
Thank you for lighting me up. So I'll give up trying and will wait to get a chance to use the nice brick or to get a spare PCB.

S!G,

I am sorry but if I "Uncover" an old 610 MB .. I will let you know.

Mike

Thumbs up for this! Laugh

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ
September 19, 2012
4:59 pm
Mike
Guest

S!G said

Mike,
Thank you for lighting me up. So I'll give up trying and will wait to get a chance to use the nice brick or to get a spare PCB.

S!G,

I am sorry but if I "Uncover" an old 610 MB .. I will let you know.

Mike

September 19, 2012
3:42 pm
S!G
Member
Forum Posts: 270
Member Since:
March 17, 2010
Offline

Mike,
Thank you for lighting me up. So I'll give up trying and will wait to get a chance to use the nice brick or to get a spare PCB.

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ
September 19, 2012
2:37 pm
Mike
Guest

S!G said

Thanks for bringing this issue into this forum. And I'm not a single step further. But I'm still sure, there is any kind of backdoor, nobody sees.
Since I do not really need this "Touch" device and I got it for my shelf, only because it looks somehow "noble", I would not send it in for any kind of exchange. Maybe, someday, I will put the 710 mainboard into this "Touch" housing. Or maybe I will get my fingers onto a 610 mainboard…

S!G

S!G,

I wish that we had the answer but it does not exist. If we had the development boards we could just do a low level format and reload all components. We have these boards for the Triton units but not the X10's

There is not a "back door" that we can find because the device driver that the iboot unit is asking for the unique development board.

We have people in Taiwan, China, Korea and Japan and they have located the board but $9000.00 USD is too much money.

For the record, San Dimas has a draw full of X10's with the error and they cannot solve it either. We should know!!

Regards to you from JG Cool

Mike

September 19, 2012
1:40 pm
S!G
Member
Forum Posts: 270
Member Since:
March 17, 2010
Offline

Thanks for bringing this issue into this forum. And I'm not a single step further. But I'm still sure, there is any kind of backdoor, nobody sees.
Since I do not really need this "Touch" device and I got it for my shelf, only because it looks somehow "noble", I would not send it in for any kind of exchange. Maybe, someday, I will put the 710 mainboard into this "Touch" housing. Or maybe I will get my fingers onto a 610 mainboard…

S!G

¡¿ʎɐqǝ ɟɟo pɹɐoqʎǝʞ sıɥʇ ʎnq ı pıp ʎɥʍ
September 19, 2012
1:01 pm
Mike
Guest

alois said

I had a familiar problem. While i did a regular software update on a eXplorist 610, an error has ocurred that resulted in a reset of the unit and from that moment the units OS was incomplete.
iBoot Error on a blue screen every time i tried to switched on the unit.

It ist now out for repair and on its way back to me.
All i needed to do a software repair on my own was a complete instruction set and the right files for a OS-update by SD-card.

S1G has the same problem with a pre-production prototype-eX610 (called "Touch"). Magellan won't replace this one again because they already did it for me and S1G got it from them for free to play with.

I would love to see a solution to do software repairs at home without the need for sending in the hardware to somewhere else.

Greetings from Germany Smile
Alois

Hello Alois, My name is Mike. I am now taking over the Forum aspect of this site while JG (the Boss) works on changing the Theme and adding more plugins.

I am very familiar with the communications between S1G. S1G and JG were discussing his prototype unit and the iBoot problem. JG informed him that we independently developed the necessary tools to reformat the drives using SD cards similar to the ones used by Magellan engineers.

These cards will not work once a unit is in the iBoot stage. The only other way would be through the USB cable but unfortunately when the unit is in the iBoot stage the USB connection does not work.

JG reference to having Magellan replace the unit was addressed at the NEW UNITS that accidentally slipped by Magellan Quality Control sector and were shipped to customers.

Unfortunately, the use of the SD card approach S1G refers to is very tricky and requires a special SDHC card which he does not have.

I apologize that we cannot provide any additional information nor do we sell or release these special cards to the public.

Regards,

Mike

September 19, 2012
11:17 am
alois
Member
Forum Posts: 19
Member Since:
March 17, 2010
Offline

I had a familiar problem. While i did a regular software update on a eXplorist 610, an error has ocurred that resulted in a reset of the unit and from that moment the units OS was incomplete.
iBoot Error on a blue screen every time i tried to switched on the unit.

It ist now out for repair and on its way back to me.
All i needed to do a software repair on my own was a complete instruction set and the right files for a OS-update by SD-card.

S1G has the same problem with a pre-production prototype-eX610 (called "Touch"). Magellan won't replace this one again because they already did it for me and S1G got it from them for free to play with.

I would love to see a solution to do software repairs at home without the need for sending in the hardware to somewhere else.

Greetings from Germany Smile
Alois

September 19, 2012
10:25 am
JungleGhost
Wayne NJ
Admin
Forum Posts: 196
Member Since:
September 15, 2012
Offline

S1G and I were communicating on this issue. What happened was that some units were accidentally placed into production and sold with the wrong software.

The units have incorrect software named "uboot" and when you attempt to do a firmware upgrade the unit crashes and no longer can boot up.

The SOLUTION: If you ever have this happen EVEN THOUGH THE UNIT IS "OUT-OF-WARRANTY" you can return it to Magellan for a new one.

Magellan is not even capable of repairing these units and has a draw full of them.

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units. Contact: SKYPE ID: edosan_go

Forum Timezone: America/New_York

Most Users Ever Online: 99

Currently Online:
16 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

phild31: 1571

David: 682

denisetdoris: 428

pprass: 279

S!G: 270

ShortcutHicksy: 258

jmebd: 193

Sockeye: 176

Caotix: 142

Paganel: 120

Member Stats:

Guest Posters: 5

Members: 806

Moderators: 0

Admins: 2

Forum Stats:

Groups: 15

Forums: 44

Topics: 938

Posts: 7403

Newest Members: Jimmer, molebaman, ElGordoManKokomo, roadbuilder, Mike, trackeruk, glad2badad, davetecsgirl, rubybegonia74, miaramra

Administrators: JungleGhost (196), Mike (0)


Add Comment Register



Leave a Reply