Explorist GC Cannot Download Caches and Menu button does not work | General GC | Forums

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Explorist GC Cannot Download Caches and Menu button does not work
cannot delete caches and can no longer download from geocaching.com
February 24, 2016
9:14 am
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 286
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

Off the cuff, your symptoms are probably being caused by a geocache that you loaded that was not HTML scrubbed. 

First advice is to:

1) Connect your GC to the PC and download the complete F:\Magellan virtual disk to your PC as a backup.

2) Next connect to VantagePoint and download all your caches, trails, etc. to your PC.

3) Next go the memory and CLEAR THE MEMORY.   Warning: this will delete all your geocaches, Trails, Routes and Waypoints.  That is why I instructed you to first create a backup of the entire contents of your GC and also to copy all the caches, etc. using VantagePoint.

4) Now test your GC to see if the problem has been solved.   Then add back one geocache at a time and see which of the caches were the bad ones.

5) Lastly, you should be using Magellan's Communication Program to download from geocache.com.  Supposedly it has a HTML scrubber to prevent a bad geocache from being loaded to your unit.

Good Luck,

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

February 23, 2016
6:30 pm
Avatar
calligal
New Member
Members
Forum Posts: 1
Member Since:
February 23, 2016
sp_UserOfflineSmall Offline

Hi:  New here...   

I have had a Magellan Explorist GC since 2011 and up until this year was able to download from geocaching .com    I've tried reinstalling and of course turning off ad blockers but it will no longer work.  

Problem #2 is trying to delete caches.  I want to delete some individual caches as per instructions by pressing the menu button...   the menu button doesn't seem to work, nothing happens when I press it...    am I doing something wrong or what.

Many thanks in advance for any helkp.

Forum Timezone: America/New_York

Most Users Ever Online: 99

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

phild31: 1564

David: 677

denisetdoris: 422

S!G: 284

pprass: 280

ShortcutHicksy: 258

jmebd: 193

Sockeye: 173

Caotix: 142

Paganel: 120

Member Stats:

Guest Posters: 5

Members: 1355

Moderators: 0

Admins: 2

Forum Stats:

Groups: 15

Forums: 45

Topics: 999

Posts: 7603

Newest Members:

YmpoRefT, Davidutere, Merrilldak, maskisa, AbanaTut, Nicanor89Mef, NancyGuine, JoeyGluse, Robertsop, Gregoryedura

Administrators: JungleGhost: 286, Mike: 25


Comments

Explorist GC Cannot Download Caches and Menu button does not work | General GC | Forums — 1 Comment

    • PLEASE FORGIVE OUR AUTOMATED RESPONSE

    Concerning your inquiry on this website. Unfortunately, we do not respond to service questions posted in the comment section of this website. If you wish to have a member of our forum assist you with a solution then post a MESSAGE on this website. May we suggest, that you JOIN the Forum. MEMBERSHIP is FREE. Do a search for your problem. If you do not find the answer then please post your question under the appropriate section. Do not use the comments section or your inquiry will not be answered. Joining is free and in this manner, both we and our membership can provide solutions. This method will also help other members. Regards, JG

Add Comment Register



Leave a Reply