WARNING: Newly issued X10's are creating iBoot errors | Bug Reporting | Forums

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
WARNING: Newly issued X10's are creating iBoot errors
Apparently some units may have been shipped that will create an iBoot nonrecoverable error when you do a 7XX firmware upgrade.
January 13, 2014
8:56 am
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 286
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

KEG,

Thanks for the information.  This unit cannot be repaired and must be replaced.

Appears as though this unit was released from Magellan with the wrong project number software.

OR we have a batch of counterfeits in motion.

Who was this unit purchased from?

JG

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

January 13, 2014
6:13 am
Avatar
Oz KEG
New Member
Members
Forum Posts: 1
Member Since:
January 13, 2014
sp_UserOfflineSmall Offline

Just tried to complete an update on a friends new 510 (in Australia) and got this exact issue.  S/N starts with 014860000 . . . .  I have sent an e-mail to Magellan, assume it will need to be sent back for a warranty repair.

December 29, 2013
2:34 pm
Avatar
JungleGhost
Wayne NJ
Admin
Forum Posts: 286
Member Since:
September 15, 2012
sp_UserOfflineSmall Offline

We would like to issue a potential WARNING.

We thank a customer who reported to me that he just purchased a 510 serial number 0148600002120 from 17th Street Photo in New York that created an iBoot error when he tried to upgrade to 713.

We are not aware that any units were released with the fifth digit of the S/N over 5.

We are also not aware that the 713 was set up to handle anything over 1-5.

The symptom was that the upgrade made it all the way through and said to disconnect and it would reboot. 

Upon reboot the unit had a BSOD (Blue Screen of Death) and gave the infamous, Updating Image, NOTE: This is iBoot Fail.

Let us know, if anyone else has had the problem.

As you know, this error cannot be repaired.

JG

 

JG is the Founder of Jungle Ghost Enterprises (JGE) in Wayne, NJ. He created JGE in 2007 specifically as a Repair and Service Center Worldwide for Magellan Triton and the New Explorist X10 units.

Forum Timezone: America/New_York

Most Users Ever Online: 99

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

phild31: 1564

David: 677

denisetdoris: 422

S!G: 284

pprass: 280

ShortcutHicksy: 258

jmebd: 193

Sockeye: 173

Caotix: 142

Paganel: 120

Member Stats:

Guest Posters: 5

Members: 1340

Moderators: 0

Admins: 2

Forum Stats:

Groups: 15

Forums: 45

Topics: 999

Posts: 7603

Newest Members:

Jasonrep, hunter84, Swadswen, KerentO, RobertExelf, DoorvanS, SormatsV, sabercycle, NotrodW, FornetC

Administrators: JungleGhost: 286, Mike: 25


Comments

WARNING: Newly issued X10's are creating iBoot errors | Bug Reporting | Forums — 1 Comment

    • PLEASE FORGIVE OUR AUTOMATED RESPONSE

    Concerning your inquiry on this website. Unfortunately, we do not respond to service questions posted in the comment section of this website. If you wish to have a member of our forum assist you with a solution then post a MESSAGE on this website. May we suggest, that you JOIN the Forum. MEMBERSHIP is FREE. Do a search for your problem. If you do not find the answer then please post your question under the appropriate section. Do not use the comments section or your inquiry will not be answered. Joining is free and in this manner, both we and our membership can provide solutions. This method will also help other members. Regards, JG

Add Comment Register



Leave a Reply